HPRE

Menu

Members Rides

2010 Military C5


in
Members Rides

Welcome, Guest. Please login or register.
Did you miss your activation email?
November 27, 2014, 01:45:57 AM

Login with username, password and session length

 

Author Topic: Engine Ticking  (Read 1415 times)

SimonT

  • Bulleteer
  • ***
  • Posts: 142
  • Karma: 0
Re: Engine Ticking
« Reply #15 on: April 28, 2011, 09:56:14 PM »
So i took it to the dealer yesterday, and he had a listen and said all is fine.

He then started up their demo bike, and it sounded equally as rattly.  I did the right thing sending it to them i think... just incase something does actually happen and something needs to be replaced under warranty.

Ducati Scotty

  • Grand Gearhead
  • *****
  • Posts: 6305
  • Karma: 0
  • 2010 Teal C5
Re: Engine Ticking
« Reply #16 on: April 28, 2011, 10:09:29 PM »
Warranty?  All you need are ear plugs and a happy go lucky attitude. :)

Scott

SimonT

  • Bulleteer
  • ***
  • Posts: 142
  • Karma: 0
Re: Engine Ticking
« Reply #17 on: April 28, 2011, 11:05:47 PM »
haha thanks for the tip ;)

prof_stack

  • Grand Gearhead
  • *****
  • Posts: 1115
  • Karma: 0
  • Ride carefully - You are invisible.
Re: Engine Ticking
« Reply #18 on: April 29, 2011, 06:15:13 PM »
Warranty?  All you need are ear plugs and a happy go lucky attitude. :)

Scott

+1
A Royal Enfield owner's cup is always half full.

cyrusb

  • Kept man
  • Grand Gearhead
  • *****
  • Posts: 2292
  • Karma: 1
  • Theres a last time for everything
Re: Engine Ticking
« Reply #19 on: April 29, 2011, 07:51:34 PM »
If it's the auto decomp then it should be fixed. I heard the video, and it has way more engine noise than my 05.  After all, it's a whole new design, that's supposed to have cured all those noises of the old design. Hydraulic lifters, no primary chain etc, but that rattle is O.K? Why?

Okie Enfield

  • Grease Monkey
  • ****
  • Posts: 408
  • Karma: 0
  • RED 2010 C5
Re: Engine Ticking
« Reply #20 on: April 30, 2011, 02:15:28 AM »
Mine does the exact same thing as in Sub's video and only has 200 miles. Dealer told me to expect it when I bought it with 19 miles on it. Said was the auto decompression valve. Waiting to see if oil changes make it go away. Other wise will just get louder exhaust! ;D