HPRE

Menu

Members Rides

CRG Hindsight Mirrors


in
Members Rides

55 Guests, 2 Users
Mr.Mazza, Scotty Brown
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 24, 2014, 08:02:13 AM

Login with username, password and session length

 

Author Topic: ES Question  (Read 1036 times)

fredgold52

  • Grease Monkey
  • ****
  • Posts: 352
  • Karma: 0
  • Macomb, IL Flatlands Rule
ES Question
« on: February 24, 2008, 10:51:37 AM »
Lately, my electric starter has had a bit of a problem engaging.  When it does, the engine starts fine.  But mostly it feels like the starter gear (?) won't stay engaged.  If it does engage, it doesn't stay that way long enough to turn the engine very far.  Then I hear the starter motor singing away under no load.

Is this a "Sprag Clutch" thing? 

Oh yeah, the bike is a 2006, 65.

Any thoughts appreciated.

Fred
2006 '65' and a 200cc Stella, Indian all the way

Vince

  • Grand Gearhead
  • *****
  • Posts: 1450
  • Karma: 0
Re: ES Question
« Reply #1 on: February 25, 2008, 03:51:19 PM »
     Yes, your starter clutch is slipping. If it is still under warranty you should take it in. If not, it's not a particularly hard job, but there are some modifications I do to try to extend it's life. If you tackle this yourself, Email me [email protected] and I will send you the info.

fredgold52

  • Grease Monkey
  • ****
  • Posts: 352
  • Karma: 0
  • Macomb, IL Flatlands Rule
Re: ES Question
« Reply #2 on: February 25, 2008, 04:38:26 PM »
Hi Vince. 

The bike is under warranty, but there's no way I'm going to let the dealer work on it.  So I'm on my own when it comes to repairs and maintenance. 

I'll be emailing you about how to fix this.

Thanks,
Fred
2006 '65' and a 200cc Stella, Indian all the way