HPRE

Menu

Members Rides

This is the before pic of the 1969


in
Members Rides

Welcome, Guest. Please login or register.
Did you miss your activation email?
November 21, 2014, 04:46:55 PM

Login with username, password and session length

 

Author Topic: Oil leak  (Read 590 times)

Dannyboy

  • Neophyte
  • *
  • Posts: 10
  • Karma: 0
Oil leak
« on: October 13, 2012, 11:09:12 AM »
Just noticed this oil leak on my C5. Looks like a seal on the electric start. Bike is still under warranty so will get my dealer to check it out.

BRADEY

  • Grease Monkey
  • ****
  • Posts: 372
  • Karma: 0
Re: Oil leak
« Reply #1 on: October 13, 2012, 05:38:12 PM »
Oil leak on a UCE is rare.............very rare. Yours is a minor one, and needs a silicon seal under the starter sprocket cover ! You can do it yourself, but if the dealer is nearby get it done under warranty. Why mess your hands just yet ;)

Arizoni

  • Grand Gearhead
  • *****
  • Posts: 4506
  • Karma: 1
  • "But it's a dry heat here in Arizona
Re: Oil leak
« Reply #2 on: October 13, 2012, 10:04:52 PM »
I'm sure the dealer will be able to fix it but if it were mine I would at least use an allen wrench to see if the bolts had loosened.

Of course, this risks breaking off one of the bolts if it gets overtightened. :(
Jim
2011 G5 Deluxe
1999 Miata 10th Anniversary

hortoncode3

  • Bulleteer
  • ***
  • Posts: 229
  • Karma: 0
Re: Oil leak
« Reply #3 on: October 16, 2012, 10:41:49 AM »
Oil leak rare? My Aunt Fanny! Mine has all sorts of drips, nothing major, cosmetic mostly...with the exception of the constant self oiling chain!   

Dannyboy

  • Neophyte
  • *
  • Posts: 10
  • Karma: 0
Re: Oil leak
« Reply #4 on: October 16, 2012, 11:06:55 AM »
I did check the bolts but all were tight so will take it to the dealer to be fixed. Thanks guys,

Dan.

hocko

  • Grease Monkey
  • ****
  • Posts: 271
  • Karma: 0
Re: Oil leak
« Reply #5 on: October 16, 2012, 10:31:08 PM »
Dannyboy Hi, I had the same leak on my '09 G5. There is no gasket there, I loosened all the screws, lifted the cover off, wiped it all over and replaced the cover with no sealant . 15000 km later still no leak. I must admit I did a 1690 km ride in two days a while back and there was slight misting on the metal but no leak as such. Hope this helps.

Cheers  :)