HPRE

Menu

Members Rides

chris-bartlett 2003 Bullet 500 Classic


in
Members Rides

46 Guests, 4 Users
johno, Veslo, solg, Droidbee
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 26, 2014, 12:56:06 PM

Login with username, password and session length

 

Author Topic: 2009 Royal Enfield won't start, sat in storage for almost a year  (Read 1127 times)

randombikerdude

  • USA Rider
  • Scooter
  • **
  • Posts: 84
  • Karma: 0
I was out of the country and stored my bike inside my condo, I drained all the fluids and removed the battery. Now I can't get it to turn over, I've replaced with fresh gas and even tried seafoam in the carb. Any ideas???

LarsBloodbeard

  • Grease Monkey
  • ****
  • Posts: 303
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #1 on: October 19, 2012, 07:41:50 PM »
Did you fog the engine when you stored it?  Is the engine frozen or does it cycle at least?

TWinOKC

  • Grand Gearhead
  • *****
  • Posts: 590
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #2 on: October 20, 2012, 03:48:21 AM »
Try the easy stuff first. 

Is the kill switch in the run position, key on, side stand up, petcock open, in neutral?
2010  C5  Teal
Triumph Bonneville T100

barenekd

  • Grand Gearhead
  • *****
  • Posts: 5403
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #3 on: October 20, 2012, 04:19:32 AM »
what do you mean, you can't get it to turn over? You can't kick it through? It just won't fire? Please clarify.
Bare
 
2013 Moto Guzzi V7 Racer
2011 Black Classic G5 (RIP)
I refuse to tiptoe through life only to arrive safely at death
http://www.controllineplans.com

randombikerdude

  • USA Rider
  • Scooter
  • **
  • Posts: 84
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #4 on: October 21, 2012, 11:41:29 PM »
I've tried the ES and KS, sounds like it wants to get going just doesn't turn over. The engine is not stuck, I can hear it. I didn't fog it, what does that mean?

boggy

  • Grand Gearhead
  • *****
  • Posts: 1818
  • Karma: 0
  • Karma Ultra: 7
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #5 on: October 21, 2012, 11:48:58 PM »
Bet my peanut butter and jelly sandwich it's the spark plug.
2007 AVL
2006 DRZ400SM

randombikerdude

  • USA Rider
  • Scooter
  • **
  • Posts: 84
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #6 on: October 22, 2012, 12:32:31 AM »
Spark Plug, that is what I was thinking.. since I've tried everything else..

LarsBloodbeard

  • Grease Monkey
  • ****
  • Posts: 303
  • Karma: 0
Re: 2009 Royal Enfield won't start, sat in storage for almost a year
« Reply #7 on: October 22, 2012, 05:01:47 AM »
I've tried the ES and KS, sounds like it wants to get going just doesn't turn over. The engine is not stuck, I can hear it. I didn't fog it, what does that mean?

A lot of people don't do this, it's more popular with boat motors.  You can save yourself some potential frustration if you do do it though.

Fogging oil comes in a spray.  You just spray it in the intake while opening the throttle a bit.  Keep spraying till it kills the engine.  That prevents internal corrosion and rust (such as, on the spark plug).

Personally, I think this is more important to do now than ever.  E10 is more corrosive than pure gas, and it collects water which will speed up rusting drastically.
« Last Edit: October 22, 2012, 05:03:57 AM by LarsBloodbeard »