HPRE

Menu

Members Rides

David in Fort Lauderdale


in
Members Rides

Welcome, Guest. Please login or register.
Did you miss your activation email?
September 18, 2014, 05:53:09 PM

Login with username, password and session length

 

Author Topic: need help/horn broke/bike sometimes kick starts doesn't stay running  (Read 1235 times)

mikejb1979

  • Neophyte
  • *
  • Posts: 19
  • Karma: 0
My Bullet Classic ES is having trouble.  Everything was fine a week ago.  In fact, i used my horn to say hi to a friend.  Then 2 days later, I'm riding home and the guy in front of me doesn't notice the light turned green.  I try my horn...silence but a discharge on the ammeter.

Ok...horn is broke.  No biggie.  I'm riding home the next day and every now and then I get some kinda misfire.  Water in the lines?  Maybe...its get warm and humid and then a dry cold front comes through.  Temps drop drastically within 24 hrs...condensation.

So, start I the bike up to ride to work today.  I always kick start.  The starter hasn't worked since day 2 of owning the bike (bought it new in March 2006).  Figured the battery was too weak to start cold.  So I kick start.  It warms up, i get on and ride off.  The bike stops running on the road.  After a few kicks...starts up again and I'm off to work.

As I'm riding, I play with the horn.  Horn still doesn't work and I noticed that as I press the horn button, the bike misfires....misses a beat.

8 hours later (after work).  I get on to ride home.  Took a few kicks, more than usual, but I got it started.  It was so many kicks I started to worry.  Let it warm up and ride off.  The bike kills as soon as I accelerate after a stop sign.  Tried kicking over and over again.  Luckily a friend from work passed by and gave me a ride home.  Had to leave the bike at work.

Could the horn not working, causing a misfire, the misfires in general and then it not running but sometimes starting be related?   I'm still new to all this and learning as i go.

Thanks!!


SRL790

  • Grease Monkey
  • ****
  • Posts: 335
  • Karma: 0
  • 1954 350
Re: need help/horn broke/bike sometimes kick starts doesn't stay running
« Reply #1 on: February 18, 2008, 02:48:03 PM »
Sounds like it may not be charging the battery.  Try putting a charger on the battery and see if it starts.  If it does then check out the charging system.  If you have access to a multimeter check the battery voltage with the bike running.  It should rise to 14 - 15 V at anything much above idle.
Andy Wiltshire
54 350 Bullet, 62 Jaguar MK II, 68 BSA Spitfire, 69 BSA Starfire
70 Bonneville, 71 Bonneville, 71 BSA B25T, 74 Jensen Healey
74 Honda XR75, 81 Yamaha MX80, 82 Suzuki GS1100G

Sam

  • Uralist & now, Bulleteer!
  • Bulleteer
  • ***
  • Posts: 196
  • Karma: 0
Re: need help/horn broke/bike sometimes kick starts doesn't stay running
« Reply #2 on: February 18, 2008, 03:54:26 PM »
horn electrics are shorting to ground, which is why it kills the ignition.
<Insert cryptic saying by obscure author here>

mrunderhill1975a

  • Grand Gearhead
  • *****
  • Posts: 660
  • Karma: 0
Re: need help/horn broke/bike sometimes kick starts doesn't stay running
« Reply #3 on: February 23, 2008, 08:02:19 PM »
I agree with Sam, horn circuit shorting to ground, discharging battery.  Not enough juice to run.

geoffbaker

  • Guest
Re: need help/horn broke/bike sometimes kick starts doesn't stay running
« Reply #4 on: March 14, 2008, 01:18:42 AM »
Let me tell you what happened to me yesterday.

I ran around town for half an hour, stopped, and the bike died completely - no juice. Every fuse I put in blew.

I started tracing wires and I found that the finned aluminum flange that bolts onto my exhaust pipe had come loose and worked its way forward just enough to touch the horn wires... and melt one.

It was grounding out completely.

You might want to follow the horn wires...